1 comment
  • It looks like dwave ping is trying to ping a hybrid solver, as that's the first one it came across. When you ping a hybrid solver you need to add an additional parameter, the time limit. The time limit is the maximum amount of time (in seconds) the hybrid solver can spend solving a problem.  Here's how you can use ping with this solver on Linux and PowerShell (for Windows):

    dwave ping -s hybrid_binary_quadratic_model_version2 --sampling-params '{"time_limit": 5}'

    If you're using Command Prompt in Windows try this instead:

    dwave ping -s hybrid_binary_quadratic_model_version2 --sampling-params "{\"time_limit\": 5}"


    Since we have different types of solvers available (qpu and hybrid), it's best to either specify

    1. The specific solver you want to ping. For example, to ping a QPU solver you could do
      dwave ping -s Advantage_system1.1
    2. The type of QPU solver you want to ping. For example, you can ping our older system, the DW_2000Q, by specifying the Chimera topology list this 
      dwave ping -s '{"topology__type": "chimera"}'
    3. The profile that the dwave CLI should look at to get the solver information. For example, if you add a profile called [qpu] that specifies a QPU solver, you could use ping like this: 
      dwave ping -p qpu


    We are working on adding another option that allows you to choose the type of solver you want to ping (QPU or hybrid). Once that is available you won't need to set the time limit when you ping a hybrid solver. But for now I recommend one of the options above.

    I hope that helps! Let me know if you have any more questions. 


    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post