UnpicklingError

My laptop has restarted after showing the blue screen error. 

When I came back to my code on jupyter notebook and tried to submit a job, I got this error message:

UnpicklingError                           Traceback (most recent call last)
<ipython-input-17-171ae9eaaff0> in <module>
      1 h,j=OptProblem(H[2:4],Y[2:4])
----> 2 sampleset = dwave_sampler.sample_ising(h,j)
      3 #print(sampleset)

~\anaconda3\lib\site-packages\dimod\core\sampler.py in sample_ising(self, h, J, **parameters)
    262         """
    263         bqm = BinaryQuadraticModel.from_ising(h, J)
--> 264         return self.sample(bqm, **parameters)
    265 
    266     @samplemixinmethod

~\anaconda3\lib\site-packages\dwave\system\samplers\dwave_sampler.py in wrapper(sampler, *args, **kwargs)
     49         while True:
     50             try:
---> 51                 return f(sampler, *args, **kwargs)
     52             except SolverOfflineError as err:
     53                 if not sampler.failover:

~\anaconda3\lib\site-packages\dwave\system\samplers\clique.py in sample(self, bqm, chain_strength, **kwargs)
    387 
    388         # get the embedding
--> 389         embedding = find_clique_embedding(bqm.variables, self.target_graph,
    390                                           use_cache=True)
    391 

minorminer\busclique.pyx in minorminer.busclique.find_clique_embedding()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache.find_clique_embedding()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache._ensure_clique_cache()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache._fetch_cache()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache._fetch_cache()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache._fetch_cache()

minorminer\busclique.pyx in minorminer.busclique.busgraph_cache._fetch_cache()

UnpicklingError: invalid load key, '\x00'.

I'm not sure how to fix this issue!

0

Comments

5 comments
  • Hello,

    You can resolve this issue by calling:

    busgraph_cache.clear_all_caches

    or by removing the files manually.

    These files should be located in the directory indicated by:

    busgraph_cache.cache_rootdir

    You can take a look at the docs here too:

    https://docs.ocean.dwavesys.com/en/stable/docs_minorminer/source/reference/clique_embedding.html#minorminer.busclique.busgraph_cache

    Would it be possible get a little more information about your system and setup?
    It would be very helpful in order for us to understand how this issue came about, so it can be avoided in the future.

    The following questions will help us better understand what might have happened to cause this state:

    1. What OS/Python/minorminer version do you have installed?
    2. Were you running code in multiple threads or in multiple processes?
    3. Did you happen to previously interrupt a calculation while it was embedding?

    In the near future, we will have some fixes for these issues as well.

    Thank you so much for your time and collaboration.

    Please let us know if you have any other questions.

    0
    Comment actions Permalink
  • Hi David,

    Thanks for your response!

    1) I work on OS: Windows 10 Home, Python: 3.8.8, minorminer:0.2.6.

    2) I run my code normally without multiple threads or multiple processes.

    3) Sometimes, I lose internet connection, but I haven't encountered this issue before I got the blue screen error and the laptop restarted.

    If you need more details please let me know.

    Regards

    0
    Comment actions Permalink
  • Thank you so much for the information. It's definitely helpful.

    The bluescreen seems like the most likely culprit.

    This shouldn't be an issue in the not too distant future.

    Were you able to clear the cache and run the problem again?

    0
    Comment actions Permalink
  • Yes, it works fine now.

    Thank you!

    1
    Comment actions Permalink
  • That's great! 
    You are very welcome.
    Thanks again for reaching out.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post